当前位置: 首页 > wordpress分享 > 正文

wordpress IP验证不当

提示wordpress IP验证不当漏洞,简介内容如下:wordpress /wp-includes/http.php文件中的wp_http_validate_url函数对输入IP验证不当,导致黑客可构造类似于012.10.10.10这样的畸形IP绕过验证,进行SSRF。

关于wordpress IP验证不当漏洞的解决办法,首先我们需要把wordpress升级到最新版本。然后做以下的修复操作即可。
1、打开/wp-includes/http.php文件,在532行左右找到:

12345if ( isset( $parsed_home['host'] ) ) {    $same_host = strtolower( $parsed_home['host'] ) === strtolower( $parsed_url['host'] );} else {    $same_host = false;}

将其修改为:

12345if (isset($parsed_home['host'])) {    $same_host = (strtolower($parsed_home['host']) === strtolower($parsed_url['host']) || 'localhost' === strtolower($parsed_url['host']));} else {    $same_host = false;};

2、在文件大约549行左右找到:

1if ( 127 === $parts[0] || 10 === $parts[0] || 0 === $parts[0]

将其修改为

1if ( 127 === $parts[0] || 10 === $parts[0] || 0 === $parts[0] || 0 === $parts[0]

修改完以上内容,再到阿里云盾控制台重新验证一下漏洞,就会发现漏洞已经不存在了

本文固定链接: https://www.ziyouwu.com/archives/1977.html | 自由屋博客www.ziyouwu.com|wordpress建站技巧分享

wordpress IP验证不当:等您坐沙发呢!

发表评论

1 + 8 = ?


快捷键:Ctrl+Enter