当前位置: 首页 > wordpress分享 > 正文

为什么wordpress需要更高的php版本

为什么PHP版本很重要

PHP是基于WordPress的编码语言,它的版本是由您的托管公司在服务器级设置的。虽然你可能熟悉保持WordPress和您的主题和插件的最新。保持PHP的最新发展也同样重要。

保持PHP最新的两个主要好处是:

网站会因为PHP的最新版本更快更高效。更新到最新支持的版本(目前为7.3版)可以提供巨大的性能提升;对于旧版本,可提高3或4倍的速度。

PHP和WordPress一样,是由它的社区维护的。因为PHP非常受欢迎,所以它是黑客攻击的目标,但是最新的版本将具有最新的安全特性。PHP的旧版本不要有这个因此,更新对于保证WordPress站点的安全至关重要。

还有以下的好处:

更快的WordPress网站将得到搜索引擎的奖励。所以你会在搜索中排名更高! 更快的网站会更好地留住访问者。(如果加载时间太长,它们就会离开),从而使您的网站更加有效。

更安全的网站能更好地抵御黑客攻击。,以及与被黑客攻击的网站相关的成本和声誉损害。 这些好处对你有好处,对你的网站访问者也有好处。

WordPress本身与PHP版本的工作时间可以追溯到5.2.4(目前推荐的版本为7.3)。

在进行之前,应该采取几个步骤来减少风险:

备份网站:备份将使您的网站恢复到现在的情况下,如果任何事情出错。确实有。提供大量免费备份插件因此,如果您还没有备份解决方案-使用其中之一。为了恢复备份,您还需要Web主机将PHP版本移回当前版本(稍后我们将讨论如何做到这一点)。

更新WordPress、主题和插件:从WordPress仪表板,头到更新,然后更新所有。无论如何,你应该经常这样做。完成后,检查您的网站是否按预期工作。

检查PHP兼容性:安装PHP兼容性检查插件检查您的主题和插件可能出现的问题。这个插件并不完美,可能会漏掉项目或标记假阳性,但在大多数情况下确实有效。

修复任何PHP兼容性问题:如果PHP兼容性检查插件发现了任何问题,请与主题或插件开发人员联系,并要求他们进行调查。如果他们不能或不愿回到你身边,看看主题或插件WordPress.org具有类似的功能,并使用其中之一。

通过这些步骤,您将准备好更新WordPress站点上的PHP版本,并享受这些带来的所有好处!

如何更新网站的PHP版本以获得更快、更安全的网站

由于PHP版本是由您的托管公司在服务器级别设置的,更新涉及到与主机设置的交互或要求主机服务商这样做,因此,怎样更新取决于您的托管公司。

原文链接:https://wordpress.org/support/update-php/ 翻译:自由屋博客

本文固定链接: https://www.ziyouwu.com/archives/1871.html | 自由屋博客www.ziyouwu.com|wordpress建站技巧分享

为什么wordpress需要更高的php版本:等您坐沙发呢!

发表评论

7 + 2 = ?


快捷键:Ctrl+Enter